Power for today.
Power for tomorrow.

ComTrader GUI 2.1

Actual version: ComTrader 2.1.2

Start ComTrader GUI (Java WebStart) »

A Java™ Runtime Environment (JRE) version 8 update 60+ including Java™ Web Start
is required on your local system to launch this application!

In case you have trouble using the webstart ComTrader version, you can use standalone package

Download ComTrader (32 bit Windows OS) » Download ComTrader (64 bit Windows OS) »


Please refer to the EPEXSPOT download section for trading related documentation

EPEX Download Section »

ComTrader Manual

Actual version: 1.1

Download Manual »

Setup guide

Actual version: 1.5

Download Setup Guide »